Securepoint Security Solutions Support Forum

Moderator: Securepoint

 
Benutzeravatar
isential gmbh
Themen-Autor
Beiträge: 128
Registriert: Di 05.05.2015, 22:17
Kontaktdaten:

hMailServer und UMA wollen nicht miteinander

Fr 08.09.2017, 19:19

Hallo!

Ich habe ein Problem, bei dem ich nicht weiterkomme.

Wir möchten eine UMA mit einem lokal installierten hMailServer betreiben. Hier zunächst die Umgebung:

UMA
  • Läuft virtuell auf einem Hyper-V unter Windows Server 2012R2
  • Version: 2.5.10
  • IP: 192.168.220.47
hMailServer
  • Läuft auf einem virtuellen Windows Server 2012R2 unter Hyper-V
  • Version: 5.6.6-B2383
  • Datenbank: MSSQL CE in der Version 5601
  • IP: 192.168.220.46
Ablauf
  • Die Clients (Outlook) arbeiten lokal über IMAP (holen) bzw SMTP (senden) mit hMailServer, was auch keinerlei Probleme verursacht.
  • hMailServer klappert unterschiedliche POP3-Konten bei 1&1 ab und legt die E-Mails lokal ab.
  • E-Mails, welche die Clients versenden, werden vom hMailServer über den 1&1-SMTP-Server verschickt.
  • Von jeder ein- und ausgehenden E-Mail fertigt hMailServer eine Kopie an und legt sie im HUB-Postfach ab.
  • Nun sollte die UMA aus diesem HUB-Postfach die zu archivierenden E-Mails über IMAP abholen, was jedoch nicht klappt.
Zunächst wollten wir ohne SSL die UMA ihre E-Mails über IMAP abholen lassen. Dabei bekamen wir folgende Fehlermeldung:

"DEBUG"    2464           "2017-09-08 18:59:37.659"                        "Creating session 137"
"TCPIP"    2464           "2017-09-08 18:59:37.659"                        "TCP - 192.168.220.47 connected to 192.168.220.46:143."
"DEBUG"    2464           "2017-09-08 18:59:37.660"                        "TCP connection started for session 136"
"IMAPD"    2464    136    "2017-09-08 18:59:37.660"    "192.168.220.47"    "SENT: * OK IMAPrev1"
"IMAPD"    3304    136    "2017-09-08 18:59:37.661"    "192.168.220.47"    "RECEIVED: 1 CAPABILITY"
"IMAPD"    3304    136    "2017-09-08 18:59:37.661"    "192.168.220.47"    "SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT NAMESPACE RIGHTS=texk[nl]1 OK CAPABILITY completed"
"IMAPD"    5744    136    "2017-09-08 18:59:37.661"    "192.168.220.47"    "RECEIVED: 2 AUTHENTICATE PLAIN"
"IMAPD"    5744    136    "2017-09-08 18:59:37.661"    "192.168.220.47"    "SENT: 2 NO Unsupported authentication mechanism."
"IMAPD"    2464    136    "2017-09-08 18:59:37.662"    "192.168.220.47"    "RECEIVED: 3 LOGOUT"
"IMAPD"    2464    136    "2017-09-08 18:59:37.662"    "192.168.220.47"    "SENT: * BYE Have a nice day[nl]3 OK Logout completed"
"DEBUG"    3304           "2017-09-08 18:59:37.662"                        "Ending session 136"
"DEBUG"    2464           "2017-09-08 18:59:37.662"                        "Creating session 138"
"TCPIP"    2464           "2017-09-08 18:59:37.663"                        "TCP - 192.168.220.47 connected to 192.168.220.46:143."
"DEBUG"    2464           "2017-09-08 18:59:37.664"                        "TCP connection started for session 137"
"IMAPD"    2464    137    "2017-09-08 18:59:37.664"    "192.168.220.47"    "SENT: * OK IMAPrev1"
"IMAPD"    3304    137    "2017-09-08 18:59:37.664"    "192.168.220.47"    "RECEIVED: 1 CAPABILITY"
"IMAPD"    3304    137    "2017-09-08 18:59:37.664"    "192.168.220.47"    "SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT NAMESPACE RIGHTS=texk[nl]1 OK CAPABILITY completed"
"IMAPD"    2464    137    "2017-09-08 18:59:37.665"    "192.168.220.47"    "RECEIVED: 2 AUTHENTICATE PLAIN"
"IMAPD"    2464    137    "2017-09-08 18:59:37.665"    "192.168.220.47"    "SENT: 2 NO Unsupported authentication mechanism."
"IMAPD"    2464    137    "2017-09-08 18:59:37.665"    "192.168.220.47"    "RECEIVED: 3 LOGOUT"
"IMAPD"    2464    137    "2017-09-08 18:59:37.665"    "192.168.220.47"    "SENT: * BYE Have a nice day[nl]3 OK Logout completed"
"DEBUG"    5744           "2017-09-08 18:59:37.666"                        "Ending session 137"


Man sieht hier insbesondere folgende Meldungen:

"RECEIVED: 1 CAPABILITY"
"SENT: * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT NAMESPACE RIGHTS=texk[nl]1 OK CAPABILITY completed"
"RECEIVED: 2 AUTHENTICATE PLAIN"
"SENT: 2 NO Unsupported authentication mechanism."

Und danach einfach Logout. Die UMA zeigt dabe folgendes an:

info: Sep 8 18:59:37 sp_fetchmail: fetching mails from Journal
err: Sep 8 18:59:37 sp_fetchmail: trying exchange workaround...
err: Sep 8 18:59:37 sp_fetchmail: Error connecting storage: login error
err: Sep 8 18:59:37 sp_fetchmail: Error connecting to 192.168.220.46.

Keine Chance gefunden, dass die UMA sich über IMAP verbindet.

Nun haben wir letzte Woche den Support angerufen. Dieser war schnell an der Stelle und schaute sich alles über Fernwartung an. Nach mehreren erfolglosen Versuchen hieß es, wir sollten es mit SSL versuchen. Der Support war auch etwas ratlos, da nach dessen Aussage es sehr viele solcher Installationen gibt.

Nun haben wir mit OpenSSL eine CA aufgebaut und eine Stammzertifikat erstellt. Darauf aufbauend haben wir einen Serverzertifikat gemacht und es auf dem Server, auf dem hMailServer ausgeführt wird, installiert (Vertrauenswürdige Stammzertifizierungsstelle). Im Anschluss daran haben wir dann ein Client-Zertifikat erstellt und es in hMailServer eingebunden.

Dieses Zertifikat (*.crt/*.key) wollten wir in die UMA als IMAP-Zertifikat importieren, die UMA weigert sich aber mit folgender Fehlermeldung:

"Fehler beim Parsen des Ergebnisses"

Nun wissen wir nicht weiter und bekommen zurzeit folgendes Protokoll, wenn wir SSL aktivieren:

"DEBUG"    4468        "2017-09-08 18:25:18.425"                        "Creating session 69"
"TCPIP"    4468        "2017-09-08 18:25:18.425"                        "TCP - 192.168.220.47 connected to 192.168.220.46:993."
"DEBUG"    4468        "2017-09-08 18:25:18.427"                        "TCP connection started for session 68"
"DEBUG"    4468        "2017-09-08 18:25:18.427"                        "Performing SSL/TLS handshake for session 68. Verify certificate: False"
"TCPIP"    5056        "2017-09-08 18:25:18.573"                        "TCPConnection - TLS/SSL handshake completed. Session Id: 68, Remote IP: 192.168.220.47, Version: TLSv1.2, Cipher: ECDHE-RSA-AES256-GCM-SHA384, Bits: 256"
"IMAPD"    5056    68  "2017-09-08 18:25:18.574"    "192.168.220.47"    "SENT: * OK IMAPrev1"
"IMAPD"    5028    68  "2017-09-08 18:25:18.612"    "192.168.220.47"    "RECEIVED: 1 AUTHENTICATE PLAIN"
"IMAPD"    5028    68  "2017-09-08 18:25:18.612"    "192.168.220.47"    "SENT: 1 NO Unsupported authentication mechanism."
"IMAPD"    4468    68  "2017-09-08 18:25:18.612"    "192.168.220.47"    "RECEIVED: 2 LOGOUT"
"IMAPD"    4468    68  "2017-09-08 18:25:18.612"    "192.168.220.47"    "SENT: * BYE Have a nice day[nl]2 OK Logout completed"
"DEBUG"    5056        "2017-09-08 18:25:18.613"                        "Ending session 68"
"DEBUG"    4468        "2017-09-08 18:25:18.613"                        "Creating session 70"
"TCPIP"    4468        "2017-09-08 18:25:18.613"                        "TCP - 192.168.220.47 connected to 192.168.220.46:993."
"DEBUG"    4468        "2017-09-08 18:25:18.615"                        "TCP connection started for session 69"
"DEBUG"    4468        "2017-09-08 18:25:18.615"                        "Performing SSL/TLS handshake for session 69. Verify certificate: False"
"TCPIP"    5056        "2017-09-08 18:25:18.762"                        "TCPConnection - TLS/SSL handshake completed. Session Id: 69, Remote IP: 192.168.220.47, Version: TLSv1.2, Cipher: ECDHE-RSA-AES256-GCM-SHA384, Bits: 256"
"IMAPD"    5056    69  "2017-09-08 18:25:18.762"    "192.168.220.47"    "SENT: * OK IMAPrev1"
"IMAPD"    4468    69  "2017-09-08 18:25:18.802"    "192.168.220.47"    "RECEIVED: 1 AUTHENTICATE PLAIN"
"IMAPD"    4468    69  "2017-09-08 18:25:18.802"    "192.168.220.47"    "SENT: 1 NO Unsupported authentication mechanism."
"IMAPD"    4468    69  "2017-09-08 18:25:18.802"    "192.168.220.47"    "RECEIVED: 2 LOGOUT"
"IMAPD"    4468    69  "2017-09-08 18:25:18.802"    "192.168.220.47"    "SENT: * BYE Have a nice day[nl]2 OK Logout completed"
"DEBUG"    5028        "2017-09-08 18:25:18.802"                        "Ending session 69"


Nun stehen wir da ziemlich ratlos und hoffen auf die Hilfe de Experten.

Im Voraus vielen Dank!

René
 
Benutzeravatar
isential gmbh
Themen-Autor
Beiträge: 128
Registriert: Di 05.05.2015, 22:17
Kontaktdaten:

Re: hMailServer und UMA wollen nicht miteinander

Di 12.09.2017, 09:46

Kann vielleicht der Support ein kurzes Wort darüber verlieren? Nur die UMA will nicht mit hMailServer, Clients wie z. B. Outlook haben dagegen überhaupt keine Berührungsängste damit.

Herzlichen Dank!

René
 
Benutzeravatar
isential gmbh
Themen-Autor
Beiträge: 128
Registriert: Di 05.05.2015, 22:17
Kontaktdaten:

Re: hMailServer und UMA wollen nicht miteinander

Do 12.10.2017, 13:47

Gibt es Neuigkeiten hierüber? Jeder Client kann über IMAP auf den hMailServer zugreifen, nur die UMA nicht. Wir haben es so gelöst, dass wir auf dem hMailServer POP3 freigeschaltet haben und die UMA über dieses Protokoll holen lassen. Trotzdem sollte man danach schauen, warum es mit IMAP nicht geht.
 
Benutzeravatar
David
Securepoint
Beiträge: 400
Registriert: Di 09.02.2016, 14:01

Re: hMailServer und UMA wollen nicht miteinander

Mo 16.10.2017, 11:24

Hallo isential,
nein keine Neuigkeiten.
Wir pflegen eine Liste mit Mailservern, welche kompatibel sind.
Wir stoßen immer wieder auf nicht RFC-konformes Verhalten, grade im Bezug auf IMAP.
Ein Beispiel wäre der 'AMTANGEE Email Connectivity Service' welcher nach einem Bugreport von uns gefixt wurde und anschließend in die Liste aufgenommen werden konnte.
Können Sie mir bitten den Versionsstand und ggf. das Patchlevel des hMailServers zukommen lassen?
Imap funkionierte mit dem hMailserver, allerdings häufen sich seit ein paar Wochen die Probleme mit IMAP (rein subjektiv, was an mir vorbeiflog.).
Mit freundlichen Grüßen

David Gundermann
Technischer Support
Tel. 04131/2401-0
Fax 04131/2401-50

Securepoint GmbH
Bleckeder Landstraße 28
D-21337 Lüneburg
http://www.securepoint.de
 
Benutzeravatar
isential gmbh
Themen-Autor
Beiträge: 128
Registriert: Di 05.05.2015, 22:17
Kontaktdaten:

Re: hMailServer und UMA wollen nicht miteinander

Mo 16.10.2017, 14:16

Version: 5.6.6-B2383
DB-Info: MSSQL CE, Version 5601
 
Benutzeravatar
David
Securepoint
Beiträge: 400
Registriert: Di 09.02.2016, 14:01

Re: hMailServer und UMA wollen nicht miteinander

Mo 16.10.2017, 15:06

danke
Mit freundlichen Grüßen

David Gundermann
Technischer Support
Tel. 04131/2401-0
Fax 04131/2401-50

Securepoint GmbH
Bleckeder Landstraße 28
D-21337 Lüneburg
http://www.securepoint.de

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste