ausgehende FTP Verbindung

Allgemeine Fragen zu Problemen. Keine Fehlerberichte oder Feature-Anfragen

Moderator: Securepoint

Antworten
Patrick Fischer
Beiträge: 51
Registriert: So 06.12.2009, 00:49

ausgehende FTP Verbindung

Beitrag von Patrick Fischer »

Hallo,

bei mir funktioniert mit der Version 11 auf einer RC100 kein FTP nach draußen mehr.
SFTP (Port 22) geht. Standardmäßig ist ja ein Dienst ftp auf Port 21 angelegt. Der Dienst ist auch in der Gruppe default-internet enthalten. Nun habe ich mich aber erinnert, dass Port 20 ja auch benötigt wird. Korrekt? Wieso ist der Port im Standard nicht angelegt? Habe also noch einen Dienst ftp-data angelegt und auch diesen in default-internet gepackt. Aber bei mir geht immer noch kein FTP. Der Browser bricht einfach irgendwann ab. Ne Idee, woran es liegt bzw. was ich falsch mache?

Patrick Fischer
Beiträge: 51
Registriert: So 06.12.2009, 00:49

Beitrag von Patrick Fischer »

Achja, im Log sehe nichts dazu.

Andreas
Securepoint
Beiträge: 124
Registriert: Di 18.03.2008, 15:56
Wohnort: Wrestedt
Kontaktdaten:

Beitrag von Andreas »

Hallo,

falls es sich um Version 11.2.x handelt, probieren Sie mal folgendes auf der CLI:

debug kmod load module nf_nat_ftp

Danach die Konfiguration speichern.

Dies lädt das conntrack-Modul für aktives FTP nach, welches u.U. nicht aktiv ist.
Such dir einen Beruf den du liebst und du musst nie wieder arbeiten! (chinesische Weisheit)

Patrick Fischer
Beiträge: 51
Registriert: So 06.12.2009, 00:49

Beitrag von Patrick Fischer »

Hallo,

ja, ist die 11.2.x.
Hab es per SSH versucht, aber da kommt eine Fehlermeldung. debug: command not found

Patrick Fischer
Beiträge: 51
Registriert: So 06.12.2009, 00:49

Beitrag von Patrick Fischer »

Ok, richtig lesen. Extras CLI - Befehl eingeben. Geht! Danke!

tsys
Beiträge: 3
Registriert: Di 12.06.2012, 10:22

Beitrag von tsys »

Ist das bei der neusten Firmware auch so? ich bekomme auch kein ausgehendes FTP hin

Gruß Matthias

Benutzeravatar
Erik
Securepoint
Beiträge: 1474
Registriert: Fr 07.11.2008, 11:50

Beitrag von Erik »

Das Kernel-Modul zu entladen war schon immer nur ein Hack, damit Möchtegern-FTP-Clients wie der Internet Exploder funktionieren. Bitte verwenden Sie einen "echten" FTP-Client. Sollte es dann immer noch nicht funktionieren, liegt die Ursache vmtl in einer fehlenden/falschen FW-Regel

tsys
Beiträge: 3
Registriert: Di 12.06.2012, 10:22

Beitrag von tsys »

Erik hat geschrieben:Das Kernel-Modul zu entladen war schon immer nur ein Hack, damit Möchtegern-FTP-Clients wie der Internet Exploder funktionieren. Bitte verwenden Sie einen "echten" FTP-Client. Sollte es dann immer noch nicht funktionieren, liegt die Ursache vmtl in einer fehlenden/falschen FW-Regel
Hallo Erik

meine Regel sieht so aus:

Netzwerkobjekt = FTPclients

FTPClients > Internet > FTP HN external interface

der FTP Zugriff wird über ein FTP Client gemacht

Gruß
Matthias

Bjoern
Securepoint
Beiträge: 541
Registriert: Mi 03.07.2013, 10:06

Beitrag von Bjoern »

Hallo,

in welchem Modus betreiben Sie FTP? Im Passive Mode müssen Sie natürlich auch die ausgehandelten Ports nach außen freigeben.

Gruß
Björn

Antworten