[Gelöst] Routing Problem mit Reverse Proxy

Allgemeine Fragen zu Problemen. Keine Fehlerberichte oder Feature-Anfragen

Moderator: Securepoint

Antworten
CHoell
Beiträge: 67
Registriert: Mo 09.03.2009, 10:49

[Gelöst] Routing Problem mit Reverse Proxy

Beitrag von CHoell »

Hallo und guten morgen.
Ich habe gleich einen Knoten im Kopf.
Hier kurz mein Problem:
Wir nutzen eine Software Telefonalge in premise im Büro.
Diese nutzte bislang doe ports 5000 und 5001 für http und https. Diese und die Standard Voip Ports wurden auf den PBX Server geforwardet.
Nun nach einem Update nutzt die PBX nur noch Port 80 und 443.
Das war dann ein Fall für den Reverse Proxy.

Leider nutzt die iOS App der PBX wohl eine Kombination aus be den Web und Voip Ports um einen Ruf aufzubauen.
Und die PBX meckert jetzt weil die Inhalte auf den Web Ports von der IP der Firewall und die Inhalte auf den SIP Ports von der IP des Telefons reinkommen.

Kann ich irgendwie das Portforwarding so konfigurieren, dass es aussieht als käme alles von der IP der Firewall.

Oder kann ich den VOIP Proxy irgendwie umgekehrt nutzen.
Stehe da grad bisschen auf dem Schlauch.

Benutzeravatar
Erik
Securepoint
Beiträge: 1479
Registriert: Fr 07.11.2008, 11:50

Beitrag von Erik »

Kann ich irgendwie das Portforwarding so konfigurieren, dass es aussieht als käme alles von der IP der Firewall.
Ja können Sie. Sie legen einfach die gleiche Regel nochmal an, wie Sie sie schon für das Portforwarding erstellt haben. Aber unten im Bereich "NAT" wählen sie aus:

Typ: HIDENAT
NAT Node: internal-interface (bzw das interface, hinter dem die TK-Anlage ist)

Speicher, Regelupdate, Profit.

Bitte beachten Sie, dass das NAT nur für neue Verbindungen greift. Wenn also ein VOIP-Client bereits registriert ist und die gesamte Zeit Daten (ungenattet) überträgt, wird sich das nicht ändern bis der mal eine Pause einlegt. Alternativ als root-User ausführen "conntrack -F" (ACHTUNG: trennt alle laufenden Verbindungen auf die UTM) oder die Appliance neu starten.

CHoell
Beiträge: 67
Registriert: Mo 09.03.2009, 10:49

Beitrag von CHoell »

Funktioniert vom Prinzip her.
Leider kann sich das Phone dann nicht mehr registrieren.
Da muss ich jetzt aber erst wieder weiter forschen wo jetzt was schief gehen kann.
Am PBX Server sehe ich Wireshark dass alles richtig ankommt.
Muss mal sehen wie ich hier weitermache.

Der Trick funktioniert ja mit dem Reverse Proxy eher nicht, oder?

CHoell
Beiträge: 67
Registriert: Mo 09.03.2009, 10:49

Beitrag von CHoell »

Ich bekomme eine Rückantwort von der PBX in Richtung UTM mit der Meldung 407 Proxy Authetication Required. Sehr seltsam

Antworten