Clientless-VPN auf Windows Server 2016

Allgemeine Fragen zu Problemen. Keine Fehlerberichte oder Feature-Anfragen

Moderator: Securepoint

Antworten
lola
Beiträge: 2
Registriert: Mi 14.10.2015, 15:03

Clientless-VPN auf Windows Server 2016

Beitrag von lola »

Hallöchen,

ich bin gerade im Praktikum, also keine Expertin, nur gleich mal vorweg.

Meine Aufgabe war es einen Server einzurichten, mit Domäne, Hyper-V, Remote Desktop Services, RemoteApps etc. Und zuletzt sollte ich noch die Securepoint UTM 11.5 in einer virtuellen Maschine aufsetzen, dass hat auch soweit alles funktioniert.
Nachdem ich jetzt den HTTP-Proxy mit der Active Directory verbunden habe, sollte ich mich der Einrichtung eines Clientless-VPN widmen.
Na ja, die Einrichtung hat nach der Anleitung in dem Securepoint Wiki auch funktioniert, aber ich bekomme einfach keine Verbindung zu meinem RDP Server, es wird immer die Fehlermeldung "Server disconnected (Code: 1006)" angezeigt.
Im Log habe ich auch mal nachgeschaut, da steht dann "WARNING: HTTP_STATUS_REDIR ACL is used in context without an HTTP response. Assuming mismatch" (Ich glaube jedenfalls das dies die Reaktion auf die versuchte Verbindung ist.)

Ich hoffe es gibt hier jemanden, der mir schnell helfen kann, schon mal danke im Voraus. :)

Mfg

lola

Illuvatar
Beiträge: 17
Registriert: Fr 21.08.2015, 16:25

Beitrag von Illuvatar »

Es kann ggfs. schon helfen mal einen anderen Browser zu nutzen. Unter Android bekomme ich mit meinen Standardbrowser die gleiche Meldung, mit Chrome z.B. klappt es jedoch.

lola
Beiträge: 2
Registriert: Mi 14.10.2015, 15:03

Beitrag von lola »

Hallo Illuvatar!


Danke für deine Antwort, aber das habe ich auch schon probiert, mit Firefox, Chrome, Edge und Internet Explorer, überall der selbe Fehler, auch unter verschiedenen Betriebssystemen.

Hast du vielleicht noch einen anderen Tipp? Ich muss ja irgendwas komplett übersehen. :blush:

Mfg

lola

EDIT: Ich hänge mal etwas vom HTTP-Proxy Log an, vielleicht hilft das ja, um zu sehen was das Problem ist.

15.10.2015 11:17:58 spfilter ALLOWED192.168.181.52 192.168.181.250 (spcgi.cgi)usr=virtualwindows10act=GLOBALDEF
15.10.2015 11:17:58 spcgi AUDITuser=VirtualWindows10remote=::ffff:192.168.181.250duration=15mscommand=clientlessvpn list
15.10.2015 11:17:58 HTTP-Proxy (squid) 192.168.181.52 192.168.181.250 (spcgi.cgi)Username=virtualwindows10
15.10.2015 11:17:58 HTTP-Proxy (squid) WARNING: HTTP_STATUS_REDIR ACL is used in context without an HTTP response. Assuming mismatch.
15.10.2015 11:17:59 spfilter ALLOWED192.168.181.52 192.168.181.250 (spcgi.cgi)usr=virtualwindows10act=GLOBALDEF

klar574
Beiträge: 2
Registriert: So 21.08.2016, 12:08

Beitrag von klar574 »

Hallo lola,

konntest Du eine Lösung für das Problem finden? Stehe gerade vor dem gleichen Problem

Gruß klar574

Kenneth
Beiträge: 348
Registriert: Mi 19.10.2011, 15:21
Wohnort: Lüneburg

Beitrag von Kenneth »

Hallo,

das sieht für mich nach einem festen Proxy aus. Können Sie es einmal mit einer lokalen Proxy Ausnahme im Browser für die IP probieren?

Gruß

Kenneth

klar574
Beiträge: 2
Registriert: So 21.08.2016, 12:08

Beitrag von klar574 »

Das Problem tritt nur in Verbindung mit Server 2016 / Windows 10 auf. Andere Systeme funktionieren ohne Probleme. Also kann es ja nur an Windows liegen. Bin bisher aber noch nicht dahinter gekommen. Gruß

redrider
Beiträge: 2
Registriert: Mo 01.06.2015, 00:27

Beitrag von redrider »

Moin,

gibt es hierzu schon was neues? Habe gerade das gleiche Problem:

1. Clientless VPN auf Win 7 Zielmaschine funktioniert
2. Clientless VPN auf WIN 10 Zielmaschine geht nicht (Fehler 1006)

Das sind zwei auf der UTM identisch konfigurierte Verbindungen (unter einem User) Authentifizierung auf Netzwerkebene auf dem WIN 10 Zielsystem ist abgeschaltet.
'Normaler' Zugang auf die Win 10 Maschine per RDP ist problemlos - auch über VPN aus Fremdnetz.

Hat jemand eine Idee ???

Bjoern
Securepoint
Beiträge: 541
Registriert: Mi 03.07.2013, 10:06

Beitrag von Bjoern »

Hallo,

ja hier muss was am template angepasst werden. Das Problem ist hier das die 2016 Server nicht mehr RDP erwarten sondern TLS. Am besten rufen Sie an oder erstellen über das Resellerportal ein Ticket. Dies soll mit der 11.8 über das Frontend pro RDP Verbindung einstellbar sein.

Gruß Björn

Benutzeravatar
David
Securepoint
Beiträge: 404
Registriert: Di 09.02.2016, 14:01

Beitrag von David »

Hallo
Seit einem unbekannten Update von Windows10, muss sowohl zusätzlich folgender Eintrag gesetzt werden:
1. Gruppenrichtlinien bearbeiten
2. Richtlinien für Lokalen Computer / Computerkonfiguration / Administrative Vorlange / Windows-Komponenten / Remotedesktopdienste / Remotedesktopsitzungs-Host / Sicherheit / Verwendung einer bestimmten Sicherheitsstufe für Remoteverbindungen (RDP) ist erforderlich || ‚Aktivieren‘ & auf ‚Aushandeln‘ stellen
3. cmd als Administrator: gpupdate /force
als auch
in Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
SecurityLayer von 2 auf 1 gesetzt werden
Mit freundlichen Grüßen

David Gundermann
Technischer Support
Tel. 04131/2401-0
Fax 04131/2401-50

Securepoint GmbH
Bleckeder Landstraße 28
D-21337 Lüneburg
http://www.securepoint.de

sivsert
Beiträge: 2
Registriert: Mi 29.08.2018, 10:22

Beitrag von sivsert »

Hallo, 
Hi, 
ich weis der Thread ist schon alt. Wollte nur mal eine Rückmeldung geben, da dies noch nicht passiert ist. 
Ich habe eine UTM V11.8.6 im Einsatz. Hinter einer FritzBox und mit SPDYN in der UTM bin ich online. Hinter Router und Firewall befindet sich mein Windows 10 Rechner, nicht in einer Domäne. 

Hier hat der Lösungsvorschlag von DAVID funktioniert. 
in Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
SecurityLayer von 2 auf 1 gesetzt werden

Danke für den Tipp und alles Gute an alle ;) 

Takvorian
Beiträge: 3
Registriert: Di 30.06.2020, 09:25

Beitrag von Takvorian »

Hallo,

ich habe hier testweise eine UTM mit der Version 11.8.8.5 mit der ich das Clientless VPN testen möchte.
Zur Verfügung habe ich einen Windows Server 2019 Standard welchen ich als Domaincontroller eingerichtet habe und 2 Benutzern den RDP Zugriff ermöglicht habe

Die AD Anbindung klappt soweit gut. Ich kann mich von extern an der UTM mit meinem Windows Benutzer (Gruppe ClientlessVPN) erfolgreich anmelden.
Wenn ich dann die ClientlessVPN Verbindung öffnen möchte bekomme ich den Fehler "1006"

Den Registry Eintrag als auch die Gruppenrichtlinie am Domaincontroller habe ich gesetzt.

Kann es sein dass das noch immer nicht alles gefixt wurde? Oder hat sich in Server 2019 wieder etwas geändert.

Gruß Tak

grand_ma64
Beiträge: 1
Registriert: So 13.09.2020, 20:00

Beitrag von grand_ma64 »

Hallo, 

ich habe das gerade auch gehabt - bei mir (UTM 11.8.8.8 und Server 2019) funktioniert das mit der angegebenen Anleitung (Eintrag in den Gruppenrichtlinien und die Änderung des Keys in der Registry). 
Aber Du musst das auf der LOKALEN Maschine machen - nicht auf dem DC: 
Bei mir hat das jedenfalls funktioniert... 

Viele Grüße
Andreas 

Antworten