Securepoint Security Solutions Support Forum

Moderator: Securepoint

 
csg
Themen-Autor
Beiträge: 169
Registriert: Di 08.03.2011, 10:55
Kontaktdaten:

Anlage neue Netzwerkobjekte / ID zählt trotz Löschen hoch

Di 29.10.2019, 15:12

Hallo zusammen,

legt man über das CLI neue Netzwerkobjekte an wird die ID hochgezählt - soweit OK.
Lösche ich aber zuvor Netzwerkobjekte, indem ich die ID ermittle, via spcli node delete id lösche, und füge dann neue Objekte hinzu, werden leider keine der gelöschten IDs verwendet, sondern es wird weiter hochgezählt.
Das ist beim Einsatz von Automatismen über das CLI und die Shell leider etwas ungünstig, da dann der ID-Counter schnell ins Unendliche wächst.
Wie kann man die IDs denn nun wirklich löschen und nicht nur die namentlich mit der ID verknüpften Objekte? Gibt es da ggf. einen Bereinigungs-/Konsolidierungsbefehl?

Danke und Grüße,

Jan
 
merlin
Beiträge: 180
Registriert: So 01.07.2007, 12:34
Wohnort: Erlangen

Re: Anlage neue Netzwerkobjekte / ID zählt trotz Löschen hoch

Di 29.10.2019, 17:21

Hallo,

das wird wohl eine Art "auto-increment"-Wert in der DB sein.

Gruß
 
csg
Themen-Autor
Beiträge: 169
Registriert: Di 08.03.2011, 10:55
Kontaktdaten:

Re: Anlage neue Netzwerkobjekte / ID zählt trotz Löschen hoch

Di 29.10.2019, 17:56

Yep, aber dass dieser Wert belegt bleibt und nicht "zurückgesetzt" wird oder werden kann, wenn es das zugehörige Objekt nicht mehr gibt ist ja eher ungünstig.
 
kennethj
Beiträge: 255
Registriert: Di 25.04.2017, 10:17

Re: Anlage neue Netzwerkobjekte / ID zählt trotz Löschen hoch

Mi 30.10.2019, 09:57

Hallo,

Naja auto-increment ist da recht Stumpf.

Er sieht ah zuletzt war es ID 15 - dann muss es jetzt 16 sein. Dadurch wird verhindert das IDs eindeutig bleiben. Eine Funktion die prüft ob es Lücken in den IDs gibt, gibt es im auto-increment nicht.

Des weiteren wirkt sich das in der Regel auch nicht negativ auf. 

Workarorund (bei Netzwerkobjekten): Man löscht das Objekt nicht, sondern ändert es nur

Gruß
 
csg
Themen-Autor
Beiträge: 169
Registriert: Di 08.03.2011, 10:55
Kontaktdaten:

Re: Anlage neue Netzwerkobjekte / ID zählt trotz Löschen hoch

Di 05.11.2019, 08:43

Hi Kenneth,

ja, aber dazu müsste man ja erstmal wissen, welche ID das Objekt aktuell hat.
Manuell ist das kein Thema, aber bei Automatismen und über 400 regelmäßig zu aktualisierenden Objekten tue ich mich da etwa schwer ...

Kann man ggf. prüfen, ob eine Node ID aktuell leer ist, diese dann mit "node set id" neu setzen?
Also so ggf. die bereits gelöschten Nodes bzw. deren IDs neu füllen?
Und wenn keine IDs mehr gesetzt und leer sind, dann mit "node new name" den Rest hinzufügen?

VG

Jan

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste