Firmware-Update wird nicht angeboten

Allgemeine Fragen zu Problemen. Keine Fehlerberichte oder Feature-Anfragen

Moderator: Securepoint

Antworten
Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Firmware-Update wird nicht angeboten

Beitrag von Karl_Kunze »

Moin,

unsere UTM läuft mit Firmware 11.8.7.2 (Final), die Lizenz läuft am 11.04.2021 ab.

Die Funktion "Firmware Updates" sagt, dass keine neuere Version zur Verfügung steht. Ich finde in der Wiki jedoch schon 11.8.8.4.

Habe ich ggfs. ein Konnektivitätsproblem?

Gruß

Karl

Benutzeravatar
Mario
Securepoint
Beiträge: 268
Registriert: Mi 04.04.2007, 10:47
Wohnort: Bäckerei

Beitrag von Mario »

Moin,

die Updates werden Staffelweise verteilt. Somit bekommen Sie das Update nicht sofort bei Release. Es koennte natuerlich auch ein Problem vorliegen, aber im Normalfall liegt es an der Art der Verteilung der Updates und an der Auslastung der Downloadslots.

Ueber die CLI kann man das Herunterladen des Updates anstoßen. "system upgrade forceupdate"

Das schlaegt unter Umstaenden ein paar Mal fehl, bis eine Downloadslot frei wird. Wenn es eine Weile dauert bis eine Reaktion des CLI kommt ist das unter Umstaendend das Zeichen, das der Download begonnen hat.
Rise from your grave!

Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Beitrag von Karl_Kunze »

Moin,

über das CLI angestoßen kommt die Meldung "downloading do-update.sh: failed".

Wie kann ich prüfen, ob die Konnektivität gegeben ist?

Gruß

Karl

Benutzeravatar
Mario
Securepoint
Beiträge: 268
Registriert: Mi 04.04.2007, 10:47
Wohnort: Bäckerei

Beitrag von Mario »

Von Außen klappt das leider nicht.

Stellen Sie sicher, das die Firewall die Standard-DNS-Server nutzt (Servereinstellungen > Primaerer Nameserver: 127.0.0.1/ Sekundaerer Nameserver: -)/ und/oder tragen Sie im DNS-Forwarding unter Nameserver einen oeffentlichen DNS-Server ein. Die Uhrzeit der Firewall sollte stimmen (Bitte den NTP-Server starten). Der Rest laeuft ueber https.
Rise from your grave!

Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Beitrag von Karl_Kunze »

Moin,

die UTM dient nur als VPN-Gateway, läuft insofern nur mit reduzierten Funktionen und auch nicht mit voller eigener Internetanbindung.D.h. bei DNS und NTP ist z. B. ein interner Server von uns eingetragen, der die entsprechenden Daten liefert.

Deswegen gehe ich davon aus, dass die Konnektivität über https zu Ihrem Server nicht gegeben ist, auch weil beim Öffnen der Konfigurationsverwaltung z. B. eine Meldung "backup_get: curl_easy_perform() failed: Couldn't connect to server" aufleuchtet.

Was da für mich ok ist, wird nun für das Firmware-Update zum Problem.

Vermutlich muss ich da noch einfach weitere Regeln in der Firewall einsetzen (welche?), aber eine Testmöglichkeit mittels Ping oder anderer Netzwerkwerkzeuge für die Erreichbarkeit Ihres Update-Servers wäre da natürlich sehr hilfreich.

Gruß

Karl

Benutzeravatar
Mario
Securepoint
Beiträge: 268
Registriert: Mi 04.04.2007, 10:47
Wohnort: Bäckerei

Beitrag von Mario »

Ok, das sieht dann stark danach aus, das deswegen keine Updates gezogen werden koennen.

Die Firewall darf alles, der muessen Sie nur den Internetzugang ermoeglichen. Regeln fuer das Update sind nicht notwendig, zumindest nicht bei der Securepoint.

Das braucht nur einen funktionierenden Internetzugang, eine Default-Route und eine funktionierende DNS-Aufloesung.
Rise from your grave!

Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Beitrag von Karl_Kunze »

Moin,

also mittels Netzwerkwerkzeuge/Ping von der externen eth0-IP-Adresse besteht Kontakt zu 8.8.8.8.

Netzwerkwerkzeuge/Host löst mittels des eigenen internen DNS-Servers www.google.de ohne Probleme auf und liefert die IP-Adresse 172.217.22.195.

Netzwerkwerkzeuge/Traceroute dorthin gibt allerdings nur "traceroute: sendto: Network is unreachable" zurück. Netzwerkwerkzeuge/Ping an 172.217.22.195 geht aber immer noch.

Also DNS-Auflösung scheint zu gehen, Internetzugang dürfte wohl auch als gegeben anzusehen sein, die Netzwerkkonfiguration/Routing beinhaltet eine Default-Route, die von dem eth0-Netzwerk Richtung Glasfaseranschlussrouter weist. Ich bin mir ziemlich sicher, das https dort dann nicht gefiltert wird.

Sind Sie ganz sicher, dass keine weitere Einstellung an der Firewall erforderlich ist?

Am liebsten wäre es mir, ich könnte diese Prüfungen anhand der Adresse Ihres Update-Servers durchführen.

Gruß

Karl

Benutzeravatar
Mario
Securepoint
Beiträge: 268
Registriert: Mi 04.04.2007, 10:47
Wohnort: Bäckerei

Beitrag von Mario »

Rise from your grave!

Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Beitrag von Karl_Kunze »

Moin,

ich bin etwas ratlos.

EInerseits (Netzwerkwerkzeuge/Host):

Using domain server:
Name: 172.16.7.1
Address: 172.16.7.1#53
Aliases:
www.heise.de has address 193.99.144.85

Andererseits (Netzwerkwerkzeuge/Host):

Using domain server:
Name: 172.16.7.1
Address: 172.16.7.1#53
Aliases:
Host updatev11.securepoint.de/ not found: 3(NXDOMAIN)

EInerseits (Netzwerkwerkzeuge/Ping):

PING www.heise.de (193.99.144.85) from 192.168.2.2: 56 data bytes
64 bytes from 193.99.144.85: seq=0 ttl=246 time=15.426 ms
64 bytes from 193.99.144.85: seq=1 ttl=246 time=14.815 ms
64 bytes from 193.99.144.85: seq=2 ttl=246 time=14.786 ms
64 bytes from 193.99.144.85: seq=3 ttl=246 time=14.882 ms
64 bytes from 193.99.144.85: seq=4 ttl=246 time=15.033 ms

--- www.heise.de ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 14.786/14.988/15.426 ms

Andererseits (Netzwerkwerkzeuge/Ping)::

ping: bad address 'updatev11.securepoint.de/'

Letzteres war ja erwartbar, trotzdem stehe ich jetzt auf dem Schlauch.

Irgendwelche Ideen?

Gruß

Karl

kennethj
Beiträge: 314
Registriert: Di 25.04.2017, 10:17

Beitrag von kennethj »

Hallo,

kann es sein das Sie den / mit kopiert haben?

ping: bad address 'updatev11.securepoint.de/'

Richtig wäre ohne "/" updatev11.securepoint.de

Gruß

Karl_Kunze
Beiträge: 19
Registriert: Di 14.04.2020, 11:25

Beitrag von Karl_Kunze »

Moin,

Blöden:

Using domain server:
Name: 172.16.7.1
Address: 172.16.7.1#53
Aliases:
updatev11.securepoint.de has address 62.201.160.29

PING updatev11.securepoint.de (62.201.160.29) from 192.168.2.2: 56 data bytes
--- updatev11.securepoint.de ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

Ich mutmaße jetzt mal, dass der Update-Server so konfiguriert ist, dass er auf Ping nicht antwortet?

Gruß

Karl

Benutzeravatar
Mario
Securepoint
Beiträge: 268
Registriert: Mi 04.04.2007, 10:47
Wohnort: Bäckerei

Beitrag von Mario »

Das ist so korrekt.
Rise from your grave!

Antworten