Windows 10 SSL VPN funktioniert nicht mehr

Allgemeine Fragen zu Problemen. Keine Fehlerberichte oder Feature-Anfragen

Moderator: Securepoint

Antworten
kultec
Beiträge: 31
Registriert: Fr 20.02.2015, 12:09

Windows 10 SSL VPN funktioniert nicht mehr

Beitrag von kultec »

Hallo,

Bei einem Kunden von uns funktioniert nach dem Update auf Windows 10 der SSL VPN nicht mehr ( Client )

Anscheinend wird der TAP Adapter nicht gefunden, eine Deinstallation sowie neu Installation des Clients hat nicht geholfen.
Gibts ein neues Paket wo ein neuer TAP Treiber enthalten ist ?

WIe könnten wir das Problem vorübergehend lösen ?

Franz
Beiträge: 394
Registriert: Sa 02.04.2011, 17:52
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Franz »

Mit der V2.0.10 aus dem Downloadbereich des Reseller-Portals bekomme ich beim Start des SSLVPNClient zwar eine Fehlermeldung und beim Import der ersten Konfiguration gibt es eine Rückfrage, aber anschließend funktioniert die VPN-Verbindung problemlos.

http://up.picr.de/22681011yn.jpg, http://up.picr.de/22681013jy.jpg

Vielleicht kann man sich so behelfen bis eine mit Windows 10 voll kompatibel Version verfügbar ist.

kultec
Beiträge: 31
Registriert: Fr 20.02.2015, 12:09

Beitrag von kultec »

also mit dem neuen Client bekomme ich immer eine Fehlermeldung :

Code: Alles auswählen

Thu Jul 30 13:22:09 2015 TLS_ERROR: BIO read tls_read_plaintext error: error:14082174:SSL routines:SSL3_CHECK_CERT_AND_ALGORITHM:dh key too small
ERROR: TLS error! See log for details
Thu Jul 30 13:22:09 2015 TLS Error: TLS object -> incoming plaintext read error
Thu Jul 30 13:22:09 2015 TLS Error: TLS handshake failed
Thu Jul 30 13:22:09 2015 SIGUSR1[soft,tls-error] received, process restarting
Thu Jul 30 13:22:09 2015 Restart pause, 2 second(s)
was kann man dagegen machen ?

Benutzeravatar
Erik
Securepoint
Beiträge: 1480
Registriert: Fr 07.11.2008, 11:50

Beitrag von Erik »


kultec
Beiträge: 31
Registriert: Fr 20.02.2015, 12:09

Beitrag von kultec »

Hallo,

Vielen Dank, werds gleich umsetzen.

Ist dies dann auch noch kompatibel mit älteren OPEN VPN Clients ?

Thomas Hartan
Beiträge: 4
Registriert: Do 30.07.2015, 19:23

Beitrag von Thomas Hartan »

Hatte selbiges Problem - bei mir hat folgendes geholfen:

In der Registry - HKLM\SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\ nach "TAP-Windows Adapter V9" suchen.
Dort die beiden Einträge "ComponentId" und "MatchingDeviceId" von "TAP0901" auf "tap0901" (also Kleinschreibung) ändern. Danach ging es sofort.

Vielleicht hilft es jemandem.


Gruß, T.

Benutzeravatar
Erik
Securepoint
Beiträge: 1480
Registriert: Fr 07.11.2008, 11:50

Beitrag von Erik »

kultec hat geschrieben:Hallo,

Vielen Dank, werds gleich umsetzen.

Ist dies dann auch noch kompatibel mit älteren OPEN VPN Clients ?
Ja, ist es.

Franz
Beiträge: 394
Registriert: Sa 02.04.2011, 17:52
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Franz »

Danke, Thomas Harten!

Bei Verwendung der V1.0.3 wird nach der kleinen Änderung in der Registry die Verbindung zwar als hergestellt signalisiert (hatte mich schon gefreut), aber leider läuft dann dennoch kein Traffic über den Tunnel.

Mit der V2.0.10 aus dem Reseller-Portal funktioniert es zuverlässig, wenn man die Fehlermeldung beim Start "Verbindung mit Service fehlgeschlagen! Bitte stellen Sie..." einfach ignoriert.

Thomas Hartan
Beiträge: 4
Registriert: Do 30.07.2015, 19:23

Beitrag von Thomas Hartan »

Hallo Franz,

vermutlich sind die Einstellungen im TAP-Adapter (Netzwerkeinstellungen) zurückgesetzt.
Ich mußte z.B. den DNS-Eintrag unserer Firmendomäne nachtragen.

Ansonsten habe das Procedere bereits bei mehreren Geräten erfolgreich durchgeführt.


Gruß, T.

pascal

Beitrag von pascal »

Nach Änderung in der Registry funktioniert der Client auch bei mir.

Manfred
Beiträge: 3
Registriert: Mi 12.02.2014, 18:25

Beitrag von Manfred »

Hallo

Durch die Änderung in der Registry funktioniert die v1.0.3 definitiv !
THX to Thomas Hartan !
Dass da kein Traffic durch den Tunnel läuft, kann ich nicht bestätigen.

Wesentlich weniger Erfolg kann ich mit der V2.0.10 ( getestet und W7 und W10 ) vermelden.
- Clienteinstellungen editieren ==> Absturz
- Import der Selben .OVPN - Datei wie bei v1.0.3 ==> Absturz

LG
Manfred

Franz
Beiträge: 394
Registriert: Sa 02.04.2011, 17:52
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Franz »

Die V1.0.3 babe ich mit den Registry-Änderungen auf einem System getestet. Weil bei den ersten Versuchen kein Traffic über den Tunnel laufen wollte, hab ich sofort auf die V2.0.10 gewechselt. Vielleicht hätte ich nur länger warten müssen. Ich werde es bei Gelegenheit nochmal testen.

Die Abstürze nach dem Bearbeiten der Einstellungen im SSL-VPN-Client V2.0.10 kann ich auch unter Win 8.1 reproduzieren. Wenn man die zuletzt bearbeitete VPN-Verbindung löscht und neu importiert, stürzt der Client nicht mehr beim Aufruf der Einstellungen ab.

Bisher habe ich die OVPN-Datei immer vor dem Import im Texteditor bearbeitet und musste anschließend allenfalls nochmal an die Check-Boxen ran, und das funktioniert problemlos. Die V2.0.10 wird sicher aus gutem Grund nicht als öffentlich zugängliche "Final" angeboten. ;)

Dietmar
Beiträge: 50
Registriert: Do 06.11.2014, 16:39

Beitrag von Dietmar »

@Thomas Hartan

Sehr guter Tipp, funktioniert einwandfrei. Vielen Dank!

spuch
Beiträge: 4
Registriert: Do 03.09.2015, 22:11

Beitrag von spuch »

kultec hat geschrieben: Gibts ein neues Paket wo ein neuer TAP Treiber enthalten ist ?
Für den Fall, das es zu einem späteren Zeitpunkt noch einmal relevant ist:
Der TAP-Adapter ist der gleiche, den auch OpenVPN benutzt, entsprechend kann der TAP-Adapter auch von dort herunter geladen werden
https://openvpn.net/index.php/open-sour ... loads.html

HINTERGRUND:
------------------------
Der SecurePoint VPN Client basiert auf dem offiziellen OpenVPN Client (https://openvpn.net).
"Securepoint unterstützt den OpenVPN-Verein und ist Unternehmens-Mitglied"

Allerdings hat SecurePoint dem OpenVPN-Client einen besseren Dämon hinzugefügt, der es auch "Normalen Usern" unter Windows 7 etc. ohne Admin Rechte erlaubt, einen VPN Tunnel auf zu machen und Scripte aus zu führen. Die OpenVPN GUI kann das leider nicht (oder besser nur mit viel Trickserei über den Taskplaner von Windows). Nach dem OpenVPN Wiki ist das zwar bekannt und eine Besserung steht auf der ToDo-Liste, allerdings scheinen dort derzeit IMHO die programmiertechnischen Ressourcen etwas knapp bemessen zu sein.

Für den Endnutzer hat das den Vorteil, dass man eine bessere GUI zusammen mit einem etablierten VPN-Client benutzen kann. Sogar die Binaries lassen sich problemlos austauschen, soll heißen: Wenn man im Unterverzeichnis "bin" des "Securepoint SSL VPN" Installationsverzeichnisses die Dateien
  1. libeay32.dll
  2. liblzo2-2.dll
  3. libpkcs11-helper-1.dll
  4. openvpn.exe
  5. ssleay32.dll
gegen die Versionen von OpenVPN 2.3.8 (released on 2015.08.04) austauscht, dann bekommt man auch jetzt schon in den Genuss, mit der derzeitigen Version 2.0.10 von SecurePoint VPN einige Fehler und Problem, die mit OpenVPN 2.3.7 "eingeschleppt" wurden gelöst zu bekommen (2.0.10 bringt OpenVPN 2.3.7 mit). Wichtig ist, dass nicht nur das exe-File ersetzt wird, denn die dlls werden beim Start dynamisch nachgeladen und müssen entsprechend passend sein. Fehler und Probleme sollte man hier im Forum allerdings nur im Zusammenhang mit den mitgelieferten Dateien posten!

Antworten